Degraded Performance in Frankfurt PoP

Minor incident Public DNS
2026-08-11 20:42 CEST · 10 minutes

Updates

Resolved

Incident is resolved while we continue our monitoring and investigation.

August 11, 2026 · 20:52 CEST
Monitoring

Monitoring is reporting that everything is back to normal and DNS traffic continues to be served without errors.

August 11, 2026 · 20:52 CEST
Issue

We are investigating a service degradation to our PoP in Frankfurt.
We will share an update in the next 10 minutes.

August 11, 2026 · 20:42 CEST

← Back