DNS4EU resolver degraded performance

Minor incident Public DNS
2026-08-20 13:25 CEST · 55 minutes

Updates

Resolved

The DNS4EU resolver performance issue has been resolved. All resolver locations are operating normally again. We will continue monitoring the service.

August 20, 2026 · 15:27 CEST
Monitoring

DNS4EU resolver performance is recovering, and most locations are operating normally. We continue to monitor the remaining elevated load and are working to restore normal performance across all locations.

August 20, 2026 · 14:58 CEST
Issue

We are investigating elevated DNS resolution latency affecting DNS4EU. Some users may experience slower DNS responses. Our team is working to restore normal performance.

August 20, 2026 · 13:49 CEST

← Back